Rebar |
Sets the Layout Rule property of rebar set to FixedNumber.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public void SetLayoutAsFixedNumber(
int numberOfBarPositions,
double arrayLength,
bool barsOnNormalSide,
bool includeFirstBar,
bool includeLastBar
)
Parameters
- numberOfBarPositions Int32
- The number of bar positions in rebar set
- arrayLength Double
- The distribution length of rebar set
- barsOnNormalSide Boolean
- Identifies if the bars of the rebar set are on the same side of the rebar plane indicated by the normal
- includeFirstBar Boolean
- Identifies if the first bar in rebar set is shown
- includeLastBar Boolean
- Identifies if the last bar in rebar set is shown

Exception | Condition |
---|---|
ArgumentOutOfRangeException | the number of bar positions numberOfBarPositions is less than 1 or more than 1002. -or- the set length arrayLength isn't acceptable. |
InapplicableDataException | This RebarContainerItem is an instance of a spiral or multiplanar shape. |

When changing the layout rule to FixedNumber, you must also simultaneously set NumberOfBarPositions, SetLength, BarsOnNormalSide, IncludeFirstBar, and IncludeLastBar properties.