Menu |
An abstract base class that represent a context menu item.

System Object
Autodesk.Revit.UI MenuItem
Autodesk.Revit.UI CommandMenuItem
Autodesk.Revit.UI SeparatorItem
Autodesk.Revit.UI SubMenuItem
Autodesk.Revit.UI MenuItem
Autodesk.Revit.UI CommandMenuItem
Autodesk.Revit.UI SeparatorItem
Autodesk.Revit.UI SubMenuItem
Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)

The MenuItem type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the MenuItem |