SplitFacesOfCuttingSolid Method


Solid Solid Cut Utils Split Faces Of Cutting Solid Method

Causes the faces of the cutting element where it intersects the element it is cutting to be split or unsplit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static void SplitFacesOfCuttingSolid(
	Element first,
	Element second,
	bool split
)

Parameters

first Element
The solid being cut or the cutting solid
second Element
The solid being cut or the cutting solid
split Boolean
True to split the faces of intersection, false to unsplit them.
Exceptions
Exception Condition
ArgumentException There is no solid-solid cut between the input elements.
ArgumentNullException A non-optional argument was null
InvalidOperationException Unable to split or unsplit faces of cutting solid
Remarks
There must be a cut between the input elements.
See Also