RevitAPIEventArgs Class


Revit APIEvent Args Class

The class is used as base class for all event argument classes.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RevitAPIEventArgs : EventArgs, 
	IDisposable

The RevitAPIEventArgs type exposes the following members.

Properties
Name Description
Public property Cancellable Indicates whether an event may be cancelled by an event delegate.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the RevitAPIEventArgs
Public method IsCancelled Indicates whether the event is being cancelled.
Top
See Also