Camera Class


Camera Class

A collection of camera settings for the current view.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.DirectContext3D Camera

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class Camera : IDisposable

The Camera type exposes the following members.

Constructors
Name Description
Public method Camera Camera
Top
Properties
Name Description
Public property EyePosition Camera's position in the world
Public property FarDistance Distance to far clipping plane
Public property HorizontalExtent Horizontal extent of the camera's view, measured at target distance.
Public property HorizontalOffset Horizontal offset of the camera's view center from target, measured at target distance.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property NearDistance Distance to near clipping plane
Public property ProjectionMethod Projection method
Public property TargetDistance Distance from camera to its target
Public property UpDirection Up direction of the camera
Public property VerticalExtent Vertical extent of the camera's view, measured at target distance.
Public property VerticalOffset Vertical offset of the camera's view center from target, measured at target distance.
Public property ViewDirection Direction that the camera is facing
Top
Methods
Name Description
Public method Dispose Releases all resources used by the Camera
Public method Transform Transforms the camera
Top
Remarks
The current Camera can be obtained from DrawContext
See Also