Element Get |
Gets the map of the external resource references referenced by the element.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public IDictionary<ExternalResourceType, ExternalResourceReference> GetExternalResourceReferences()
Return Value
IDictionary ExternalResourceType , ExternalResourceReferenceThe map of the external resource references referenced by the element.

Exception | Condition |
---|---|
InvalidOperationException | This Element does not use any external resource. |

For an element which has multiple external resource references under a specified type like AppearanceAssetElement, the first one will be the value in the map. See also: [!:Autodesk::Revit::DB::Element::getExternalResourceReferencesExpanded] .