GetViewRectangle Method


Draw Context Get View Rectangle Method

Gets the rectangle that represents the extent (in 2D) of the Revit view where rendering takes place.

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static Rectangle GetViewRectangle()

Return Value

Rectangle
The view rectangle.
Exceptions
Exception Condition
InvalidOperationException This DrawContext is not available because Revit is not currently rendering. In general, this DrawContext must be used in the scope of the RenderScene() callback of IDirectContext3DServer.
See Also