Family |
Create new Form elements by revolve operation, and add them into the Autodesk Revit family document.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

public FormArray NewRevolveForms(
bool isSolid,
ReferenceArray profile,
Reference axis,
double startAngle,
double endAngle
)
Parameters
- isSolid Boolean
- Indicates if the Form is Solid or Void.
- profile ReferenceArray
- The profile of the newly created revolution. It should consist of only one curve loop. The profile must be in the same plane as the axis.
- axis Reference
- The axis of revolution. The axis is a line that must lie in the same plane as the curves in the profile.
- startAngle Double
- The start angle of Revolution in radians.
- endAngle Double
- The end angle of Revolution in radians.
Return Value
FormArrayIf creation was successful new forms are returned.

Typically this operation produces only a single form, but some combinations of arguments will create multiple forms from a single profile.