FamilyType Class


Family Type Class

The family type object provides read access to the values of family parameters for this type.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FamilyType : APIObject

The FamilyType type exposes the following members.

Properties
Name Description
Public property Code example IsReadOnly Identifies if the object is read-only or modifiable.
(Inherited from APIObject )
Public property Name The name of the family type.
Top
Methods
Name Description
Public method AsDouble Provides access to the double precision number of the given family parameter.
Public method AsElementId Provides access to the Autodesk::Revit::DB::ElementId^ stored in the given family parameter.
Public method AsInteger Provides access to the integer number of the given family parameter.
Public method AsString Provides access to the string contents of the given family parameter.
Public method AsValueString Provides access to value as a string with unit in the given family parameter.
Public method Dispose Causes the object to release immediately any resources it may be utilizing.
(Inherited from APIObject )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method HasValue Indicates if this family parameter has an assigned value or not.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also