Project Method


Surface Project Method

Project a 3D point orthogonally onto a surface (to find the nearest point). Throws InvalidOperationException if the projection fails.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void Project(
	XYZ point,
	out UV uv,
	out double distance
)

Parameters

point XYZ
The point to project.
uv UV
The surface coordinates of the projected point.
distance Double
Holds the distance from input point to its projection.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
InvalidOperationException The projection failed.
See Also