ExternalServiceOptions Class


External Service Options Class

Various options affecting the behavior of an External Service
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.ExternalService ExternalServiceOptions

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ExternalServiceOptions : IDisposable

The ExternalServiceOptions type exposes the following members.

Constructors
Name Description
Public method ExternalServiceOptions Constructs a new ExternalServiceOptions with default settings.
Top
Properties
Name Description
Public property IsPublic This property denotes a service as either public or private.
Public property IsRecordable Indicates whether executions of the service is recorded in documents or not.
Public property IsSelfsynchronizing Indicates whether the service's record of used services (in a particular document) can independently wary between local clients and the corresponding central model. It is then up to the service's owner to assure proper local-central synchronization.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property SupportActivation Indicates if the service supports activation/deactivation of the servers.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the ExternalServiceOptions
Top
Remarks
Options are provided at the time of registering a service. After a service is registered, the options cannot be changed.
See Also