ExtensibleStorageFilter Class


Extensible Storage Filter Class

A filter used to filter elements with extensible storage data based on specific Schema id.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ElementFilter
Autodesk.Revit.DB ElementQuickFilter
Autodesk.Revit.DB.ExtensibleStorage ExtensibleStorageFilter

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ExtensibleStorageFilter : ElementQuickFilter

The ExtensibleStorageFilter type exposes the following members.

Constructors
Name Description
Public method ExtensibleStorageFilter Constructs a new instance of a filter to match elements with extensible storage data based on specific Schema id.
Top
Properties
Name Description
Public property SchemaGuid Schema id used to filter elements with extensible storage data
Top
Methods
Name Description
Top
Remarks
This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.
See Also