Create Method (ExporterIFC, Boolean)


IFCProduct Wrapper Create(Exporter IFC, Boolean) Method

Establishes a new baseline product manager for elements and objects.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static IFCProductWrapper Create(
	ExporterIFC ExporterIFC,
	bool allowRelateToLevel
)

Parameters

ExporterIFC ExporterIFC
The exporter.
allowRelateToLevel Boolean
True to allow associated elements and objects to relate to a level, false to never allow such a relationship.

Return Value

IFCProductWrapper
The new baseline product manager.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
Elements and objects associated to this product manager will be associated to a top-level IfcProduct based on the world coordinate system of the output file.
See Also