External |
Returns the instance that provides implementation for a registered server.
Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- serverId Guid
- Id of a registered server
Return Value
IExternalServerAn instance of the server interface. NULL is returned if the server is invalid (e.g. destroyed)

Exception | Condition |
---|---|
ArgumentException | The given Id is not a valid GUID value. |