AnalyticalModelSelector Constructor (Curve, AnalyticalCurveSelector)


Analytical Model Selector(Curve, Analytical Curve Selector) Constructor

Creates a selector based on one portion of a specific analytical curve.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public AnalyticalModelSelector(
	Curve curve,
	AnalyticalCurveSelector inCurveSelector
)

Parameters

curve Curve
The curve upon which this selector acts.
inCurveSelector AnalyticalCurveSelector
Portion of the analytical curve in which the client is interested.
Exceptions
Exception Condition
ArgumentException The input curve points to a helical curve and is not supported for this operation.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also