IsEqual Method


Document Version Is Equal Method

Checks whether two DocumentVersions are identical. They are identical if both the GUID and number of saves are equal. If two DocumentVersions are identical, they come from the same document, with the same set of changes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsEqual(
	DocumentVersion other
)

Parameters

other DocumentVersion
The DocumentVersion to compare to this DocumentVersion.

Return Value

Boolean
True if the two DocumentVersions are equal. False otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also