WallLocationLine Enumeration


Wall Location Line Enumeration

This enumerated type represents the options for alignment of a wall's location line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum WallLocationLine
Members
Member name Value Description
CoreCenterline 1 The wall location line is aligned to the center of the core.
CoreExterior 4 The wall location line is aligned to the exterior face of the core.
CoreInterior 5 The wall location line is aligned to the exterior face of the core.
FinishFaceExterior 2 The wall location line is aligned to the exterior face of the wall.
FinishFaceInterior 3 The wall location line is aligned to the interior face of the wall.
WallCenterline 0 The wall location line is aligned to the center of the wall.
See Also