ElementStructuralTypeFilter Constructor (StructuralType, Boolean)


Element Structural Type Filter(Structural Type, Boolean) Constructor

Constructs a new instance of a filter to match elements by structural type, with the option to match all elements which are of the given structural type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementStructuralTypeFilter(
	StructuralType structuralType,
	bool inverted
)

Parameters

structuralType StructuralType
The structural type to match.
inverted Boolean
True if the filter should match all elements which are not of the given structural type.
Exceptions
Exception Condition
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also