SwitchPhases Method


Panel Schedule View Switch Phases Method

Switches the circuit phases at the slot.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SwitchPhases(
	int nRow,
	int nCol
)

Parameters

nRow Int32
Row Number.
nCol Int32
Column Number.
Exceptions
Exception Condition
ArgumentException The circuit at given cell (nRow, nCol) is not one or two poles circuit.
ArgumentOutOfRangeException The given row number nRow is invalid in Body. -or- The given column number nCol is invalid in Body. -or- There is no circuit at given cell (nRow, nCol).
InvalidOperationException This is not a switchboard panel schedule.
Remarks
Only one or two poles circuit on switchboard panel schedule can switch phases.
See Also