BuiltInFailures.GridChainSketchFailures Class


Built In Failures Grid Chain Sketch Failures Class

Failures related to the GridChain sketch.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BuiltInFailures GridChainSketchFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class GridChainSketchFailures

The BuiltInFailures GridChainSketchFailures type exposes the following members.

Properties
Name Description
Public property Static member ClosedLoop GridChain sketch contains a closed loop.
Public property Static member InvalidSketch Sketch is invalid. Grid sketch must consist of a single open loop with no intersecting lines.
Public property Static member MoreThanOneLoop GridChain sketch contains more than one loop.
Public property Static member OverlappingLines GridChain sketch contains lines which overlap.
Top
See Also