Hardwood Class


Hardwood Class

A static class that provides access to the property names that appear in the Hardwood visual asset schema.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Visual Hardwood

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class Hardwood

The Hardwood type exposes the following members.

Properties
Name Description
Public property Static member CommonTintColor The property labeled "Tint Color" from the "Hardwood" schema.
Public property Static member CommonTintToggle The property labeled "Tint" from the "Hardwood" schema.
Public property Static member HardwoodApplication The property labeled "Used For" from the "Hardwood" schema.
Public property Static member HardwoodColor The property labeled "Image" from the "Hardwood" schema.
Public property Static member HardwoodFinish The property labeled "Finish" from the "Hardwood" schema.
Public property Static member HardwoodImperfections The property labeled "Relief Pattern" from the "Hardwood" schema.
Public property Static member HardwoodImperfectionsAmount The property labeled "Amount" from the "Hardwood" schema.
Public property Static member HardwoodImperfectionsShader The property labeled "Image" from the "Hardwood" schema.
Public property Static member HardwoodTintColor The property labeled "Stain Color" from the "Hardwood" schema.
Public property Static member HardwoodTintEnabled The property labeled "Stain" from the "Hardwood" schema.
Top
See Also