SolidCurveIntersection Class


Solid Curve Intersection Class

This class represents the results of a calculation of intersection between a solid volume and a curve.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB SolidCurveIntersection

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class SolidCurveIntersection : IEnumerable<Curve>, 
	IDisposable

The SolidCurveIntersection type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property ResultType The result type used to calculate the intersections.
Public property SegmentCount The number of segments in the results.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the SolidCurveIntersection
Protected method GetBasicIEnumerator Returns an enumerator that iterates through a collection.
Public method GetCurveSegment Gets the curve segment generated by intersection.
Public method GetCurveSegmentExtents Gets the extents for the given curve segment generated by intersection.
Public method GetEnumerator Returns an enumerator that iterates through a collection.
Top
Remarks
The results contain a collection of curves and a collection of curve extents (which are the parameters of intersection from the original input curve). Depending on the SolidCurveIntersectionMode option passed when executing the calculation, the curve segments and curve extents represent either the extents of the curve which exist inside the solid, or the extents of the curve which exist outside the solid. If the curve is entirely inside the solid, and the option is CurveSegmentsOutside, or if the curve is entirely outside the solid, and the option is CurveSegmentsInside, this results object will be empty. Note that curves aligned with the bounding faces of the solid are considered to be inside by this utility.
See Also