AreaReinforcement Class


Area Reinforcement Class

An object that represents an Area Reinforcement within the Autodesk Revit project.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB Element
Autodesk.Revit.DB.Structure AreaReinforcement

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class AreaReinforcement : Element

The AreaReinforcement type exposes the following members.

Properties
Name Description
Public property AdditionalBottomCoverOffset Additional offset from the bottom or interior cover reference.
Public property AdditionalTopCoverOffset Additional offset from the top or exterior cover reference.
Public property AreaReinforcementType Retrieves the type of the Area Reinforcement.
Public property Direction Retrieve the Major Direction of the Area Reinforcement.
Top
Methods
Name Description
Public method Static member ConvertRebarInSystemToRebars Converts all RebarInSystem elements owned by the input AreaReinforcement to equivalent Rebar elements.
Public method Static member Create(Document, Element, XYZ, ElementId, ElementId, ElementId) Creates a new AreaReinforcement object based on a host boundary.
Public method Static member Create(Document, Element, IList Curve , XYZ, ElementId, ElementId, ElementId)
Public method GetBoundaryCurveIds Retrieves the set of curves forming the boundary of the Area Reinforcement.
Public method GetHostId The element that contains the Area Reinforcement.
Public method GetLayerDirection Gets the direction of the layer. The lines are distributed along this direction.
Public method GetLineFromLayerAtIndex Gets the line from the desired layer at the specified index.
Public method GetMovedLineTransform Returns a transform representing the movement of the line relative to its default position along the direction of the desired layer.
Public method GetNumberOfLines Gets the number of lines on the specified layer. It also counts the excluded ones.
Public method GetRebarInSystemIds Returns the ids of the RebarInSystem elements owned by the AreaReinforcement element.
Public method IsLayerActive Identifies if the layer is active or not.
Public method IsLineIncluded Checks whether the line from the desired layer at the specified position is included or not.
Public method IsUnobscuredInView Checks if Area Reinforcement is shown unobscured in a view.
Public method MoveLine This method applies the translation to the line from the desired layer, at the specified position. If the line was already moved, the method will concatenate the translation with the existing movement. The line will be translated only along the direction of the specified layer.
Public method Static member RemoveAreaReinforcementSystem Deletes the specified AreaReinforcement, and converts its RebarInSystem elements to equivalent Rebar elements.
Public method ResetMovedLineTransform Reset the transformation representing the movement of the line relative to its default position along the direction of the specified layer. The moved line transform will be set to Identity.
Public method SetLayerActive Sets if the desired layer is active or not.
Public method SetLineIncluded Sets if the line from desired layer at the specified position is included or not.
Public method SetUnobscuredInView Sets Area Reinforcement to be shown unobscured in a view.
Top
Remarks
This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object. The Area Reinforcement element is available only in the Autodesk Revit Structure product.
See Also