Failures |
Changes the name of the transaction for which failures are being processed.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- transactionName String
- The name of the transaction to set.

Exception | Condition |
---|---|
ArgumentException | transactionName is an empty string. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing). |

If the transaction will be committed by or after failures processing it can change its name to reflect results of processing of the failures. For example, if the original transaction name was "review warnings" and some of the warnings were resolved by deleting of the relevant elements, failures processor may change the name of the transaction to "delete elements".