Panel |
Gets the value of the apparent current parameter for a spare
Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public double GetSpareCurrentValue(
int row,
int column,
ElementId idCurrentParameter
)
Parameters
- row Int32
- A row where the valid spare is
- column Int32
- A column where the valid spare is
- idCurrentParameter ElementId
- One of 4 valid current parameters: RBS_ELEC_APPARENT_CURRENT_PARAM, RBS_ELEC_APPARENT_CURRENT_PHASEA_PARAM, RBS_ELEC_APPARENT_CURRENT_PHASEB_PARAM, RBS_ELEC_APPARENT_CURRENT_PHASEC_PARAM
Return Value
DoubleThe value of the spare's current parameter

Exception | Condition |
---|---|
ArgumentException | The current parameter id is not valid. |
ArgumentNullException | A non-optional argument was null |
ArgumentsInconsistentException | The row column combination does not represent a valid spare. |