Direct |
Adds a reference plane to the DirectShapeType. The reference plane can either be bounded or unbounded.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public void AddReferencePlane(
Plane refPlane,
BoundingBoxUV boundingBoxUV,
DirectShapeReferenceOptions options
)
Parameters
- refPlane Plane
- The geometry of the new reference plane.
- boundingBoxUV BoundingBoxUV
- If boundingBoxUV is set, the resulting reference plane that is added to the DirectShapeType will be displayed with those bounds. Note that the specified bounds must not be degenerate. If boundingBoxUV is not set, reasonable bounds are automatically calculated and applied to the input plane. The automatic bounds are based on the host direct shape's geometry.
- options DirectShapeReferenceOptions
- The options that are used to configure the new reference plane.

Exception | Condition |
---|---|
ArgumentException | boundingBoxUV cannot be used as a BoundingBoxUV for the reference plane surface. -or- options cannot be used to add a reference object to this DirectShapeType. |
ArgumentNullException | A non-optional argument was null |