RebarPresentationInView Property


Reinforcement Settings Rebar Presentation In View Property

The default presentation mode for rebar sets, when the view direction is perpendicular to the rebar normal and the rebar set is not cut.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public RebarPresentationMode RebarPresentationInView { get; set; }

Property Value

RebarPresentationMode
Exceptions
Exception Condition
ArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Remarks
All bars in a given rebar set will be visible if:
  • The view is a 3D view.
  • The view direction is not parallel to the rebar normal.
For this case there are no defaults and no overrides in instances.
See Also