PointOnFace Class


Point On Face Class

Define a ReferencePoint relative to a Face.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class PointOnFace : PointElementReference

The PointOnFace type exposes the following members.

Properties
Name Description
Public property UV The location of the point in the surface's coordinate system.
Top
Methods
Name Description
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetFaceReference Get a copy of the face reference.
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method SetFaceReference Change the face reference.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
A ReferencePoint on a Face has its X and Y basis vectors parallel to the Face, but is free to rotate around its Z basis vector. It must lie on the face (unlike PointOnPlane).
See Also