Add Method


Export Pattern Table Add Method

Inserts a (key,info) pair into Export pattern table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void Add(
	ExportPatternKey exportPatternKey,
	ExportPatternInfo exportPatternInfo
)

Parameters

exportPatternKey ExportPatternKey
The export pattern key to be added.
exportPatternInfo ExportPatternInfo
The export pattern info to be added.
Exceptions
Exception Condition
ArgumentException The key already exists in the table.
ArgumentNullException A non-optional argument was null
See Also