BuiltInFailures.ViewFailures Class


Built In Failures View Failures Class

Failures about ViewFailures.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BuiltInFailures ViewFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class ViewFailures

The BuiltInFailures ViewFailures type exposes the following members.

Properties
Name Description
Public property Static member BadViewDirectionSetting Plan view DBViewType has invalid view direction parameter.
Public property Static member CanNotDeleteLastOpenView Deleting of all open views in a project is not allowed.
Public property Static member CannotPasteViewReferences Cannot paste view references into the view they reference or into unrelated views
Public property Static member CannotToggleToPerspective Cannot toggle to perspective view because the view contains annotations.
Public property Static member DetailNumberDuplicate Detail Number is already in use. Enter a unique number.
Public property Static member DetailNumberEmpty Detail Number is empty
Public property Static member InitialViewDeleted The starting view for the project has been deleted.
Public property Static member InsertColumnViewError Column cannot be placed in Elevation or Section view
Public property Static member InsertColumnViewFailure Column cannot be placed in Elevation or Section view
Public property Static member InsertComponentViewError This type of Component cannot be placed in Elevation or Section view
Public property Static member InsertComponentViewFailure This type of Component cannot be placed in Elevation or Section view
Public property Static member InvalidDBviewScopeBox The scope box and view must have parallel vertical axes.
Public property Static member NoTargetsForDependentViewPropagation There are no valid views. Only views without dependents can be used.
Public property Static member NothingToApplyError Start and end elevations are the same, nothing to Apply.
Public property Static member NothingToApplyWarning Start and end elevations are the same, nothing to Apply.
Public property Static member ReloadLatestDeletedLastOpenView The only open view has been deleted because of changes from the Central Model. Open another view and Reload Latest or Synchronize with Central again.
Public property Static member TurnCropRegionOffRemovesViewBreaks Turning off the Crop Region of the view will remove all View Breaks. If the Crop Region is turned on at a later time, any desired View Breaks must be created again.
Public property Static member ViewPublishFailed The following views could not be published.
Public property Static member ZeroLengthViewBreaksRemoved Some View Regions were consolidated. When the size of a View Break between View Regions becomes zero, the View Break is removed and the adjacent View Regions are joined.
Public property Static member ZeroLengthViewRegionsRemoved Some View Regions were removed. When the size of a View Region becomes zero, it is removed from the view.
Top
See Also