IFCAnyHandle Class


IFCAny Handle Class

A handle representing an item in an IFC file.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.IFC IFCAnyHandle

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class IFCAnyHandle : IDisposable

The IFCAnyHandle type exposes the following members.

Properties
Name Description
Public property HasValue Identifies if the handle is empty or contains a value.
Public property Id The integer identifier for the handle.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property StepId The step id of the handle. Valid only for import.
Public property TypeName The name of the type of the handle.
Top
Methods
Name Description
Public method CreateAggregateAttribute Creates an attribute that is an aggregate. TODO: Rename to createAggregateByRef
Public method Delete Deletes the handle.
Public method Dispose Releases all resources used by the IFCAnyHandle
Public method Equals Determines whether the specified Object is equal to the current Object .
(Overrides Object Equals(Object) )
Public method GetAttribute Gets the attribute by name.
Public method GetHashCode Gets the integer value of the id as hash code
(Overrides Object GetHashCode )
Public method IsSubTypeOf Determines whether the instance is an instance of the specified instance type or a subtype of this instance type.
Public method IsTypeOf Determines whether the instance is an instance of exactly the specified instance type.
Public method SetAttribute(String, IFCAnyHandle) Sets the attribute value.
Public method SetAttribute(String, IFCData) Sets the attribute value.
Public method SetAttribute(String, Boolean) Sets the attribute value.
Public method SetAttribute(String, IList IFCAnyHandle )
Public method SetAttribute(String, IList Boolean )
Public method SetAttribute(String, IList Double )
Public method SetAttribute(String, IList Int32 )
Public method SetAttribute(String, IList String )
Public method SetAttribute(String, ISet IFCAnyHandle )
Public method SetAttribute(String, ISet Boolean )
Public method SetAttribute(String, ISet Double )
Public method SetAttribute(String, ISet Int32 )
Public method SetAttribute(String, ISet String )
Public method SetAttribute(String, Double) Sets the attribute value.
Public method SetAttribute(String, Int32) Sets the attribute value.
Public method SetAttribute(String, String) Sets the attribute value.
Public method UnsetAttribute Unsets the attribute value.
Top
Operators
Name Description
Public operator Static member Equality(IFCAnyHandle, IFCAnyHandle) Determines whether two IFCAnyHandles are the same.
Public operator Static member Inequality(IFCAnyHandle, IFCAnyHandle) Determines whether two IFCAnyHandles are different.
Top
Remarks
Handles are used to populate each line item in an IFC file. Each handle is assigned a unique identifier (an integer) which can be seen in the file contents at the start of the line.
See Also