TemporaryViewMode Enumeration


Temporary View Mode Enumeration

Enumeration to represent the various temporary view modes a view can be in.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum TemporaryViewMode
Members
Member name Value Description
ExplodedView 6 The view is in the mode that shows the model in exploded view and allows user changes/configurations
PreviewFamilyVisibility 8 The view is in the mode that shows visibility settings applied in the environment of a family document.
RevealConstraints 7 The view is in the mode that reveals constraints between elements in the model.
RevealHiddenElements 1 The view is in reveal hidden elements mode
TemporaryHideIsolate 2 The view is in temporary hide/isolate mode
TemporaryViewProperties 4 The view is in the selected View Properties applied temporarily.
WorksharingDisplay 3 The view is in one of the worksharing display modes
See Also