Initial |
This class encapsulates initial luminous intensity calculation.

System Object
Autodesk.Revit.DB.Lighting InitialIntensity
Autodesk.Revit.DB.Lighting InitialLuminousIntensity
Autodesk.Revit.DB.Lighting InitialIntensity
Autodesk.Revit.DB.Lighting InitialLuminousIntensity
Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The InitialLuminousIntensity type exposes the following members.

Name | Description | |
---|---|---|
![]() | InitialLuminousIntensity(Double) | Creates an initial luminous intensity object with the given document and luminosity values. |
![]() | InitialLuminousIntensity(InitialLuminousIntensity) | Creates a copy of the given initial luminous intensity object |

Name | Description | |
---|---|---|
![]() | InitialIntensityValue | The calculated initial intensity value. (Inherited from InitialIntensity ) |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from InitialIntensity ) |
![]() | Luminosity | The luminosity value. |

Name | Description | |
---|---|---|
![]() | Clone | Creates a copy of the InitialIntensity derived object. (Inherited from InitialIntensity ) |
![]() | Dispose | (Inherited from InitialIntensity ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |