SystemsAnalysisOptions Class


Systems Analysis Options Class

Contains the options for systems analysis.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Analysis SystemsAnalysisOptions

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class SystemsAnalysisOptions : IDisposable

The SystemsAnalysisOptions type exposes the following members.

Constructors
Name Description
Public method SystemsAnalysisOptions Constructs a new instance of the options.
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property OutputFolder The path of the output folder for systems analysis.
Public property WeatherFile The file name of the EnergyPlus weather (*.epw).
Public property WorkflowFile The file name of the EnergyPlus workflow script.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the SystemsAnalysisOptions
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also