AdvancedGlazing Class


Advanced Glazing Class

A static class that provides access to the property names that appear in the AdvancedGlazing visual asset schema.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Visual AdvancedGlazing

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class AdvancedGlazing

The AdvancedGlazing type exposes the following members.

Properties
Name Description
Public property Static member GlazingBackfaceCulling The property labeled "Backface Culling" from the "AdvancedGlazing" schema.
Public property Static member GlazingF0 The property labeled "Reflective Color" from the "AdvancedGlazing" schema.
Public property Static member GlazingTransmissionColor The property labeled "Transmissive color" from the "AdvancedGlazing" schema.
Public property Static member GlazingTransmissionRoughness The property labeled "Transmissive roughness" from the "AdvancedGlazing" schema.
Public property Static member SurfaceAlbedo The property labeled "Color" from the "AdvancedGlazing" schema.
Public property Static member SurfaceAnisotropy The property labeled "Anisotropy" from the "AdvancedGlazing" schema.
Public property Static member SurfaceCutout The property labeled "Image" from the "AdvancedGlazing" schema.
Public property Static member SurfaceNdfType The property labeled "NDF" from the "AdvancedGlazing" schema.
Public property Static member SurfaceNormal The property labeled "Image" from the "AdvancedGlazing" schema.
Public property Static member SurfaceRotation The property labeled "Rotation" from the "AdvancedGlazing" schema.
Public property Static member SurfaceRoughness The property labeled "Roughness" from the "AdvancedGlazing" schema.
Top
See Also