StructuralSectionISplitSlopedFlange Constructor (Double, Double, Double, Double, Double, Double, Double, Double, Double, Double, Double, Double, Double, Double, Double, Double, Double, Double, Double, Double, Double, Double, Double, Double, Double, Double, Double, Double, Double)


Structural Section ISplit Sloped Flange Constructor

Creates a new instance of Structural Section I Split Sloped Flange shape with the associated set of parameters, used to attach to structural element.

Namespace: Autodesk.Revit.DB.Structure.StructuralSections
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public StructuralSectionISplitSlopedFlange(
	double width,
	double height,
	double flangeThickness,
	double flangeThicknessLocation,
	double webThickness,
	double webFillet,
	double flangeFillet,
	double centroidHorizontal,
	double centroidVertical,
	double principalAxesAngle,
	double sectionArea,
	double perimeter,
	double nominalWeight,
	double momentOfInertiaStrongAxis,
	double momentOfInertiaWeakAxis,
	double elasticModulusStrongAxis,
	double elasticModulusWeakAxis,
	double plasticModulusStrongAxis,
	double plasticModulusWeakAxis,
	double torsionalMomentOfInertia,
	double torsionalModulus,
	double warpingConstant,
	double shearAreaStrongAxis,
	double shearAreaWeakAxis,
	double clearWebHeight,
	double webToeOfFillet,
	double boltSpacing,
	double boltDiameter,
	double slopedFlangeAngle
)

Parameters

width Double
Section width.
height Double
Section height, depth.
flangeThickness Double
Flange Thickness.
flangeThicknessLocation Double
Flange Thickness Location.
webThickness Double
Web Thickness.
webFillet Double
Web Fillet - fillet radius between web and flange.
flangeFillet Double
Flange Fillet - fillet radius at the flange end.
centroidHorizontal Double
Distance from centroid to the left extremites along horizontal axis.
centroidVertical Double
Distance from centroid to the upper extremites along vertical axis.
principalAxesAngle Double
Rotation angle between the principal axes and cross section reference planes.
sectionArea Double
Cross section area.
perimeter Double
Painting surface of the unit length.
nominalWeight Double
Unit weight (not mass) per unit length, for self-weight calculation or quantity survey.
momentOfInertiaStrongAxis Double
Moment of Inertia about main strong axis (I).
momentOfInertiaWeakAxis Double
Moment of Inertia about main weak axis (I).
elasticModulusStrongAxis Double
Elastic section modulus about main strong axis for calculation of bending stresses.
elasticModulusWeakAxis Double
Elastic section modulus about main weak axis for calculation of bending stresses.
plasticModulusStrongAxis Double
Plastic section modulus in bending about main strong axis (Z, Wpl)
plasticModulusWeakAxis Double
Plastic section modulus in bending about main weak axis.
torsionalMomentOfInertia Double
Torsional Moment of inertia (J, IT, K), for calculation of torsional deformation
torsionalModulus Double
Section modulus for calculations of torsion stresses (Ct)
warpingConstant Double
Warping constant (Cw, Iomega, H)
shearAreaStrongAxis Double
Shear area (reduced extreme shear stress coefficient) in the direction of strong axis (Wq).
shearAreaWeakAxis Double
Shear area (reduced extreme shear stress coefficient) in the direction of weak axis (Wq).
clearWebHeight Double
Detailing depth between the web toes of the fillets, in.(mm)
webToeOfFillet Double
Detailing distance from outer face of flange to web toe of fillet, in. (mm)
boltSpacing Double
Standard bolt spacing, in. (mm)
boltDiameter Double
Maximum bolt hole diameter, in. (mm)
slopedFlangeAngle Double
Sloped flange angle. (rad)
See Also