GetParamValue Method


Panel Schedule View Get Param Value Method

Gets the cell's text based on its type

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public string GetParamValue(
	SectionType sectionType,
	int nRow,
	int nCol
)

Parameters

sectionType SectionType
Section of the desired parameter value
nRow Int32
Row Number of the Section
nCol Int32
Column Number of the Section

Return Value

String
The cell's text
Exceptions
Exception Condition
ArgumentOutOfRangeException The given row number nRow is invalid. -or- The given column number nCol is invalid. -or- Thrown if there is no parameter at this cell -or- A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException Thrown if attempt to call on a template
See Also