Worksharing |
Takes a path to a central model and copies the model into a new local file for the current user.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters

Exception | Condition |
---|---|
ArgumentException | The given path sourcePath is a cloud path which is not supported in this method. -or- The model is not workshared. -or- The central model has not fully enabled worksharing. It must be opened and resaved to finish enabling worksharing. -or- The model is a local file. -or- The central model is not saved in the current Revit version. -or- The model is transmitted. -or- -or- The specified filepath is invalid. |
ArgumentNullException | A non-optional argument was null |
CentralModelAccessDeniedException | Access to the central model was denied due to lack of access privileges. -or- Access to the central model was denied. A possible reason is because the model was under maintenance. |
CentralModelContentionException | The central model is locked by another user. -or- The central model is being accessed by another client. |
CentralModelException | The central model is missing. -or- An internal error happened on the central model, please contact the server administrator. |
FileArgumentAlreadyExistsException | The file or folder already exists and cannot be overwritten. |
InvalidOperationException | This functionality is not available in Revit LT. -or- File already exists! -or- Revit Server does not support local models. |
RevitServerCommunicationException | The server-based central model could not be accessed because of a network communication error. |
RevitServerInternalException | An internal error happened on the server, please contact the server administrator. |