NewLinearDimension Method (View, Line, ReferenceArray)


Family Item Factory New Linear Dimension(View, Line, Reference Array) Method

Generate a new linear dimension object using the default dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public Dimension NewLinearDimension(
	View view,
	Line line,
	ReferenceArray references
)

Parameters

view View
The view in which the dimension is to be visible.
line Line
The extension line of the dimension.
references ReferenceArray
An array of geometric references to which the dimension is to be bound. You must supply at least two references, and all references supplied must be parallel to each other and perpendicular to the extension line.

Return Value

Dimension
If creation was successful the new linear dimension is returned, otherwise an exception with failure information will be thrown.
Exceptions
Exception Condition
ArgumentNullException Thrown when any input argument is .
ArgumentException Thrown when the argument "references" is invalid.
InvalidOperationException Thrown when the creation failed.
Remarks
The currently user set default style is used for the created dimension.
See Also