Create Method


Structural Connection Approval Type Create Method

Creates a new StructuralConnectionApprovalType.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static StructuralConnectionApprovalType Create(
	Document doc,
	string name
)

Parameters

doc Document
name String
A name for the new approval type. It must be unique within the document.

Return Value

StructuralConnectionApprovalType
Created connection approval type.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
ArgumentsInconsistentException The input name for approval type is not unique in the document.
See Also