Curve Intersect(Curve) Method |
Calculates the intersection of this curve with the specified curve.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- curve Curve
- The specified curve to intersect with this curve.
Return Value
SetComparisonResult- SetComparisonResult.Overlap - One or more intersections were encountered.
- SetComparisonResult.Subset - The inputs are parallel lines with only one common intersection point, or the curve used to invoke the intersection check is a line entirely within the unbound line passed as argument curve.
- SetComparisonResult.Superset - The input curve is entirely within the unbound line used to invoke the intersection check.
- SetComparisonResult.Disjoint - There is no intersection found between the two curves.
- SetComparisonResult.Equal - The two curves are identical.

Exception | Condition |
---|---|
ArgumentNullException | The specified curve is . |
InvalidOperationException | Failed to calculate the intersection. |