CreateLinkReference Method


Reference Create Link Reference Method

Creates a Reference from a Reference in an RVT Link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Reference CreateLinkReference(
	RevitLinkInstance revitLinkInstance
)

Parameters

revitLinkInstance RevitLinkInstance
Id of the RevitLinkInstance that contains the reference.

Return Value

Reference
Exceptions
Exception Condition
ArgumentNullException Thrown when revitLinkInstance is .
Remarks
The reference that is returned can be used to create a family instance on a face in an RVT link.
See Also