FilterViewId Property


IFCExport Options Filter View Id Property

Id of the view whose visibility settings will govern the contents in the exported IFC file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementId FilterViewId { get; set; }

Property Value

ElementId
This should be set to the id of the view, or InvalidElementId if there is to be no special filtering applied (all model elements will be exported). Default is InvalidElementId.
Exceptions
Exception Condition
ArgumentNullException When setting this property: A non-optional argument was null
See Also