IFCCategory |
Gets a copy of ifc mapping info by category id.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public ExportIFCCategoryInfo GetMappingInfoById(
Document document,
ElementId categoryId,
CustomSubCategoryId customSubCategoryId
)
Parameters
- document Document
- A Revit document.
- categoryId ElementId
- The category id.
- customSubCategoryId CustomSubCategoryId
- The custom subcategory id.
Return Value
ExportIFCCategoryInfoReturn the info for this category.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |