IFCFileWriteOptions Class


IFCFile Write Options Class

This class contains options to write an IFC file.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.IFC IFCFileWriteOptions

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class IFCFileWriteOptions : IDisposable

The IFCFileWriteOptions type exposes the following members.

Constructors
Name Description
Public method IFCFileWriteOptions Creates a default IFCFileWriteOptions. The default file format is ifc.
Top
Properties
Name Description
Public property FileFormat The file format of the IFC file.
Public property FileName The full file name of the IFC file to be written.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the IFCFileWriteOptions
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also