LeftSideSupportType Property


Stairs Type Left Side Support Type Property

The type of left support used in the stair.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementId LeftSideSupportType { get; set; }

Property Value

ElementId
Exceptions
Exception Condition
ArgumentException When setting this property: leftSideStringerTypeId is not a valid support type. -or- When setting this property: The specified leftSideStringerTypeId doesn't match the desired style of the left side support.
ArgumentNullException When setting this property: A non-optional argument was null
InvalidOperationException When setting this property: The left support style is none, so this related data cannot be set.
See Also