LinePatternSegment Class


Line Pattern Segment Class

Represents a segment in a line pattern.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB LinePatternSegment

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class LinePatternSegment : IDisposable

The LinePatternSegment type exposes the following members.

Constructors
Name Description
Public method LinePatternSegment Creates a line pattern segment.
Public method LinePatternSegment(LinePatternSegmentType, Double) Creates a line pattern segment with given type and length.
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Length Gets and sets the length of the segment.
Public property Type Gets and sets the type of the segment.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the LinePatternSegment
Top
See Also