SetSpecificFittingAngleStatus Method


Duct Settings Set Specific Fitting Angle Status Method

Sets the status of given specific angle.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetSpecificFittingAngleStatus(
	double angle,
	bool useInLayout
)

Parameters

angle Double
The specific angle (in degree) that must be one of 60, 45, 30, 22.5 or 11.25 degrees.
useInLayout Boolean
Status, true - using the given angle during the duct layout.
Exceptions
Exception Condition
ArgumentOutOfRangeException The given value for angle must be 90, 60, 45, 30, 22.5 or 11.25 degrees.
InvalidOperationException Can not set an angle status for an invalid angle.
See Also