Intersect Method (Face, Curve)


Face Intersect(Face, Curve ) Method

Calculates the intersection of the specified face with this face and returns the intersection results.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public FaceIntersectionFaceResult Intersect(
	Face face,
	out Curve result
)

Parameters

face Face
The specified face to intersect with this face.
result Curve
A single Curve representing the intersection.

Return Value

FaceIntersectionFaceResult
  • FaceIntersectionFaceResult.Intersecting - One or more intersections were encountered.
  • SetComparisonResult.NonIntersecting - There is no intersection found.
Exceptions
Exception Condition
ArgumentNullException The face is .
InvalidOperationException The intersection calculation fails.
Remarks
This is not a general-purpose function: it only works properly for simple configurations. For other configurations, it may return an incorrect result. Some configurations for which the function might return a correct result are:
  • A planar face that fully intersects another face in a single curve, when the other face is planar or cylindrical.
  • A cylindrical face that fully intersects another face in a single curve, when the other face is planar.
See Also