Create Method


Nurbs Surface Data Create Method


Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static NurbsSurfaceData Create(
	int degreeU,
	int degreeV,
	IList<double> knotsU,
	IList<double> knotsV,
	IList<XYZ> controlPoints,
	IList<double> weights,
	bool bReverseOrientation
)

Parameters

degreeU Int32
degreeV Int32
knotsU IList Double
knotsV IList Double
controlPoints IList XYZ
weights IList Double
bReverseOrientation Boolean

Return Value

NurbsSurfaceData
See Also